Back to overview
Maintenance
Application maintenance
Jun 20, 2026 at 12:00pm UTC
–
Jun 20, 2026 at 2:35pm UTC
Affected services
Main application
Resolved
Jun 20, 2026 at 2:35pm UTC
Maintenance completed in 2 hours and 35 minutes.
Affected services
Created
Jun 20, 2026 at 12:00pm UTC
We’ll be performing scheduled maintenance starting at 8:00 am ET. The process is expected to take approximately 3 hours, during which the application will be temporarily unavailable.
Periodic downtime is essential for releasing new features and making important improvements. We strive to minimize these interruptions and appreciate your understanding as we continue to grow together.
Affected services