Transactional email delivery
Resolved
Jan 22 at 11:59pm EST
AWS has confirmed full service restoration. The issue has been resolved, and emails are being delivered without delay.
Affected services
Updated
Jan 22 at 07:00pm EST
Most emails are being delivered without delay, though AWS has not yet confirmed full recovery.
Affected services
Updated
Jan 22 at 05:30pm EST
Email delivery delays continue to improve as AWS works toward full recovery with its provider.
Affected services
Updated
Jan 22 at 04:45pm EST
AWS has implemented mitigations that are improving email delivery latency and delays are decreasing.
Affected services
Created
Jan 22 at 04:15pm EST
We are experiencing delays in the delivery of emails related to password resets and two-factor authentication due to increased processing latency in AWS.
Affected services